蓝冠官网-蓝冠公司|蓝冠招商注册-蓝冠开户
蓝冠官网(主管Q374919)

蓝冠总代平台官网_Cisco OSPF Trunk测试 (求助)

小弟在做网路模拟架构测试时遇到的问题,想请问大神们该如何解?拜托各位IT大神指导,先谢过!!
如图:

条件
1.想要PC0~PC3互ping成功
2.SW0—-SW1之间为Trunk Mode
3.两台Switch做OSPF动态路由
4.建立一个新的Vlan作为互连不同网段互连的虚拟vlan(vlan13)

问题:
1.PC0与PC2、PC1与PC3有成功Ping通(同网段),但不同网段互ping 失败(vlan11ping不到vlan12),是哪里有设定错误或是少了哪些设定?
2.做完OSPF后,show ip route没有出现OSPF的路由条目,是为什么呢?
(以上,求助于大神,恳请提供援助,由衷感谢!!
指令:
SW0

Switch>enable
Switch#conf t

Switch(config)#vlan 11
Switch(config-vlan)#exit

Switch(config)#vlan 12
Switch(config-vlan)#exit

Switch(config)#interface vlan 11
Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.11.254 255.255.255.0
Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 11
Switch(config-if)#no shutdown
Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 12
Switch(config-if)#no shutdown
Switch(config-if)#exit

SW1

Switch>en
Switch>enable
Switch#conf t

Switch(config)#vlan 11
Switch(config-vlan)#exit

Switch(config)#vlan 12
Switch(config-vlan)#exit

Switch(config)#interface vlan 12
Switch(config-if)#ip address 192.168.12.254 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 11
Switch(config-if)#no shutdown
Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 12
Switch(config-if)#no shutdown
Switch(config-if)#exit

SW0

Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#no shutdown
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk

SW1

Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#no shutdown
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk

SW0 建立Vlan 13 作为不同网段互通

Switch(config)#vlan 13
Switch(config-vlan)#exit
Switch(config)#interface vlan 13
Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.13.1 255.255.255.0
Switch(config-if)#exit

SW1 建立Vlan 13 作为不同网段互通

Switch(config)#vlan 13
Switch(config-vlan)#exit
Switch(config)#interface vlan 13
Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.13.1 255.255.255.0
Switch(config-if)#exit

SW0 开启及设定OSPF 动态路由
Switch(config)#ip routing
Switch(config)#router ospf 1
Switch(config-router)#network 192.168.11.0 0.0.0.255 area 10
Switch(config-router)#network 192.168.13.0 0.0.0.255 area 10
Switch(config-router)#exit

SW1 开启及设定OSPF 动态路由
Switch(config)#ip routing
Switch(config)#router ospf 1
Switch(config-router)#network 192.168.12.0 0.0.0.255 area 10
Switch(config-router)#network 192.168.13.0 0.0.0.255 area 10
Switch(config-router)#exit

2022-10-04